こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

AHCI BIOS not installed

DELLのInspiron530Sで、OSがWindows7です。
先日、電源を入れたら真黒な画面に白文字で
タイトルの表示が出ました。

電源を入れてすぐにF12を連打しても同じで、
次にF2を連打したらBIOSの画面になり、
CDROMから起動するようにしたのですが、
再起動するとやはり同じ画面になります。

ドライブにはOSのディスクを入れていて
再インストールしたいのですが出来ずに
います。

どうすればいいでしょうか?

投稿日時 - 2017-03-02 19:26:42

QNo.9300243

困ってます

質問者が選んだベストアンサー

状況としては
AHCI BIOS not installed
の表示が出たまま止まってますか?
それとも、表示が消えた状態で止まってますか?

起動直後にF12キーを連打すると起動デバイス選択メニューが表示されます。
そこからCD/DVDを選択して起動出来るかを確認してください。

このPCは大分長い期間使っていると思われますので、CMOS電池の交換をしてみてください。
手順は、
本体から電源ケーブルを抜きます。
本体のカバーを外して、マザーボードが見える状態にします。
ボタン電池が載っているはずですので、それと同型の電池を用意し、入れ替えてください。
次に、マザーボード上にCLR_CMOSと書かれたジャンパピンがあるはずです。
ピンが3本立っていて、そのうちの2本がカバーで覆われている形になってます。
そのカバーを注意深く取り外し、反対側の2本に差し込みます。
10秒待ち、再度反対側の2本に差し替えます。

PCを元通りにして起動してみてください。

なお分解方法と、ボタン電池、CMOSジャンパピンについて不明の場合には以下のページを参考にしてみてください。
英文ですが途中に図が載ってます。
http://support.feelpcs.com/pc-spec/Inspiron530S/parts.htm#wp1508953
http://support.feelpcs.com/pc-spec/Inspiron530S/appendix.htm#wp1151275

投稿日時 - 2017-03-07 10:06:27

お礼

No.7にお礼を書いた後、締め切ろうかと
いうところでこの回答を頂いていた事に
気づきました。

これは試してみたかったです。大変勉強に
なりました。ありがとうございました。

投稿日時 - 2017-03-22 08:10:06

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(7)

ANo.7

その後、進展はありましたか。
> AHCI BIOS installed
このエラーメッセージだけでは、原因ははっきりしませんけど。
その前に、このエラーは、何故出たのかです。
あるデバイスを認識できないときに出ます。
あるデバイスとは、このエラーメッセージの最初に出力されているはずです。
例えばこんな感じで、
> Controller Bus#00 , Device#1F , Function#02:02ports,02 Devices
> Port-00:Hard Disk,ST3160812AS
> Port-01:CDROM,Optiarc DVD+/-RW AD-5540A
ここに記載されている情報は、認識できているデバイスかも知れません。
ということは、
> CDROMから起動するようにしたのですが、
それができないのではないかと思われます。
CD/DVD-ROMの電源部とコネクタ部の接触不良がないか、
それでもダメな時は、この内蔵CD/DVD-ROMを諦めてこの電源部コネクタ部を外し、USB接続CD/DVD-ROMと交換するか、
内蔵CD/DVD-ROMを新規に購入し交換してみるとかしないとダメかも知れません。

先のエラー表示の解説として、
> Port-00:Hard Disk,ST3160812AS
は、内蔵HDD
> Port-01:CDROM,Optiarc DVD+/-RW AD-5540A
は、内蔵CD/DVD-ROM
をそれぞれ表示しています。
こうしたことを理解したうえで不明点等あれば、補足願いたい。

投稿日時 - 2017-03-22 03:44:31

お礼

詳しくありがとうございます。

久しぶりに電源を入れてみたところ、ファンの音がして
2~3秒後に電源が落ちてしまいます。

質問するとしたら別件になるので、締め切る事にします。

投稿日時 - 2017-03-22 08:02:40

ANo.5

ありがとうございます

ではもう少し調べてみます

投稿日時 - 2017-03-06 21:03:51

ANo.4

BIOS初期化は効果無しですか。

長時間放置はやってみましたか?

投稿日時 - 2017-03-06 13:18:45

補足

すみません、書いてなかったですね。
長期放置も変わらずでした。

投稿日時 - 2017-03-06 18:28:52

ANo.3

すいません、言葉足らずでした。
Windowsが起動出来ているかどうかを確認したかったんですが、起動できていないと言う事で了解しました。

同じ様な状態になった人が長時間放置したら起動出来たと言う書き込みがあったので試して欲しかったんです。
その人の場合、夜寝る前に電源を入れた状態にしていたら、朝起きた時には起動していたと言う事なので、取り敢えず「半日」としました。

なおBIOSには入れる様なので、BIOSの初期化(デフォルト状態にする)をやってみる価値もあります。

両方共駄目な場合には他の方法を考えます。

投稿日時 - 2017-03-04 09:07:30

補足

http://www.dell.com/support/article/jp/ja/jpbsd1/SLN294169/biosを初期化する方法?lang=JA

こちらの3をやってみましたがダメでした。

投稿日時 - 2017-03-06 08:42:25

ANo.2

おはようございます

PCは起動出来ているんですか?
もし
AHCI BIOS not installed
が表示された時点で起動が止まっている場合、その表示が出た状態で半日ほど放置してみてください。

投稿日時 - 2017-03-03 09:18:45

補足

すみません、PCは起動出来ているんですか?
というのが良く分からず・・・

電源は入りますがWindowsは立ちあがらない
状態です。

ちなみに半日放置するとどうなるんでしょうか?

投稿日時 - 2017-03-03 20:30:15

ANo.1

USBデバイスを接続している場合は、いったん外してPC起動してみてください。
BIOS設定での起動順は(1)CD/DVDドライブ(2)HDDドライブに設定してPC起動してみてください。

投稿日時 - 2017-03-02 20:29:39

お礼

すみません、補足を書いたはずと思っていたのですが、
投稿されていない事に気づきました。

久しぶりに電源を入れてみたところ、ファンの音がして
2~3秒後に電源が落ちてしまいます。

質問するとしたら別件になるので、締め切る事にします。

投稿日時 - 2017-03-22 08:06:37