こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

ビデオカード増設後のBIOS画面について

V520を購入してから以前から持っていたビデオカードを増設しましたところ、
BIOSの画面が増設したビデオカードからの出力に映りません。
画面が1つしかないため、確認ができないのですがBIOSはオンボードの出力で立ち上がってWindowsの画面から増設したビデオカードの出力で立ち上がっているように思います。

BIOS、Windowsの両方を増設したビデオカードへ出力は可能でしょうか。

※OKWAVEより補足:「Lenovo:デスクトップ(IdeaCentre・Lenovo等)」についての質問です。

投稿日時 - 2018-01-24 01:51:29

QNo.9421639

暇なときに回答ください

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

ご自分の情報を正確に書くことがまず第一です、
V520にはオプションでグラボを載せられるようですが購入のPCにはオンボードのグラフィック機能だけということですね。

UEFIもBIOSも同じものと考えて画面出力は内蔵を優先にするか外付けグラボを優先にするしかありません、内蔵優先の場合は先に内蔵グラフィックチップを読みに行き外付けを読みに行くので全ての画面出力が可能になります。

外付け優先の場合は最初からグラボを読みに行くので内蔵出力はできません、この場合は最初からグラボに出力されますが仕様によってRGBかDVI(HDMIなど)か端子を変えて確認するしかありませんがWindowsが立ち上がったら画面の設定で好きな画面に設定して再起動すれば希望通りになります(この設定は複数ディスプレイでやります)がディスプレイが一つの場合は接続端子を取り替えて確認するしかありません。

UEFIはメーカーによって違いがあるのでグラフィクの切り替えが判りづらいこともあるので注意が必要です、複数画面で設定できるならWindowsの画面設定で好きな画面をメインにできるので簡単ですが一ディスプレイでは出力端子に繋ぐしか方法はないと思います。

あくまで参考意見ですのでよく考へて取り組んで下さい。

投稿日時 - 2018-01-25 13:31:32

補足

わかりづらくて申し訳ありませんでした。

いずれにしても、内蔵のみのときにもRGBは映るがHDMIは映らないないという現象もなぜ起きるのかよくわかりません。

投稿日時 - 2018-01-26 20:30:00

BIOSの設定が内蔵グラフィックスと増設したGPUでのデュアルディスプレイ環境になっていませんか?
メインディスプレイが内蔵グラフィックスでサブディスプレイがGPUの環境ですとBIOSはメインディスプレイに表示されます。
BIOS(UEFI)で内蔵グラフィックスとのデュアルディスプレイ設定を無効にしてみてください。

投稿日時 - 2018-01-24 08:54:25

補足

残念ながら、BIOSの設定でそういったことが設定できないんですね。
ディスプレイの選択みたいなところで、AUTOからPEGへと設定を変更しても、だめでした。

投稿日時 - 2018-01-26 20:27:20

ANo.4

あーーーーわかった。

マザーボードにビデオがオンボードなのに、PCIだかにもう一枚挿したので、2箇所接続があるのね?

通常、追加で刺すと追加のほうが有効になるけど、有効無効は電源が入ったときに決める場合もある。
私の場合、追加したビデオの方に接続、DEL か F2 か F12 でROM-BIOSまで行き、マザーボード側のオンボードビデオを無効し設定し、保存してます。

どちらが有線か? を設定できるのにも出会ってます。今は「択一」で、両方使えるようにはできないと思います。

VIDEOも nVidia か ATI(AMD) しか無いので、これを2枚さすと4画面可能だと思います。

思います・・・・というのは、2個のPCIをケーブルで繋ぎ、連動させるのは経験しても、2画面までなんですよ、経験。

投稿日時 - 2018-01-24 07:36:40

補足

BIOSの設定もグラフィックカードの設定をするところぐらいしか見つからず、
「PEG/IGD/AUTO」からどれか選ぶことしかできないようです。
デフォルトの「AUTO」を「PEG」変更してやっても増設のRGBではBIOSの画面は映りませんでした。

投稿日時 - 2018-01-24 19:30:20

ANo.3

質問の意味が不明。
1画面(モニタ一つ)で、何でBIOSがCPU内蔵で、Win本体がビデオカードって何って感じ?
ここで疑問なのが、CPU内蔵ビデオならば10が起動するのは当然としても、ビデオカードでBIOS画面が起動しないとしたら、この意味も不明?
自作PC的に考えるとしたら、高速起動等で設定されている場合、BIOSなんてでないです。起動時にDeleteキーを押すなどしたら、UEFIBIOSが表示されます。ここでUEFIで10がインストールされてるとしたら、自作で使うマザーボードの場合、GIGABYTE、MSI、ASUS、ASRockなどのメーカー名が電源オンで最初に表示され、そのままの画面で10が起動します。ASRock、MSIなどの高速起動だと、起動用ユーティリティや回復(設定)にあるUEFI ファームウェアの設定で表示するしかないわけですし。
V520の起動画面はLenovo?になるのかな、10のLenovoのPC(デスクトップ)は使ったことがないので個人的にはわからない。安いLenovoのPCでビデオカード使う人なんて少ないでしょうし。

ビデオカードでBIOSを表示できないとしたら、このビデオカードが昔の非UEFIタイプである可能性。
現在、自作PC8台使っていて、ビデオカード使用は7台。1台はAPU。7枚のビデオカードはすべてUEFI対応であり、UEFIでインストールされてる10で、わざわざ非UEFIのビデオカードを使うなどの実験はしたことがないのでどうなるのかはわからないですしね。電源オンでフリーズしてしまうような気もするが、V520の場合、10が起動してしまってるので、この点も不明。
ググっても、古いマザボで今のUEFI対応のビデオカードが使えるのかどうかの質問しか見つからない。最新のマザボで古いビデオカードを使って、10をインストールする場合、レガシーのMBRでのインストールになるわけで、V520のBIOS画面が表示されないってのもいまいちわからないです。
ASRock(AM4)のマザボとSapphire(Radeon)のRX(580、480など)を使うと、10の起動画面はASRock/Sapphireと表示されることもあります。

投稿日時 - 2018-01-24 05:29:34

補足

ありがとうございます。

そうなんですよ。何って感じなんですよね。
工場出荷時に、内蔵のグラフィックボードにHDMI出力あるの気付かずRGBで見てみてその後、増設のグラフィックボード挿してしまったので、もともとHDMIで正しく映ったのかも今となってはわかりません。内蔵のHDMIでWindowsは映りますけれども。。
結局、BIOS設定したかったら、RGB端末のあるモニタでないと設定できないです。メインのモニタがRGB端末ありませんので、とても不便です。

グラボは新しくもないですが、nvidea GTX650になります。

投稿日時 - 2018-01-24 19:28:21

お礼

うまくいっていた内蔵のRGB端子にモニタ繋いだままで、Windowsのスタートメニューを押しながらShiftの再起動でUEFIを選んで再起動した時に何も映らないというのはやはりグラボがUEFI非対応の可能性高そうですね。

投稿日時 - 2018-01-24 19:41:06

そのBIOSを触ったことがないので、なんともいえませんが、
もしかしたら、どっちを初期化するかの設定が
内臓グラフィックになっているのではないかと思います。
Windows起動後は、ついているグラフィック全部が初期化されるので、
写ると言う具合。
ということで、モニターを内臓側に差し替えて、
BIOSから、増設側グラフィックを優先するようにすると、
以後、増設側のボードで映るかもしれません。
(その機種を持っていないので、その設定があるかは、不明です)

なお、BIOSで画面が出るかと、Windowsで画面がでるかは、
あまり関係はないです。
こちらの環境では、マルチモニターで、BIOSでは、そのうち2画面しか
出ませんが、Windows起動後は、全モニターが表示できると言う感じで
この辺は、ボードなどの仕様で異なるようですね。

投稿日時 - 2018-01-24 05:18:54

補足

ありがとうございます。
おっしゃるように、BIOSで画面どうこう関係ないというのはそのとおりかもしれません。

内蔵でもHDMIはだめで、RGBしか映らないようです。
増設を外して内蔵のHDMIのみに繋いでみましたが映りませんでした。

BIOSの設定もグラフィックカードの設定をするところぐらいしか見つからず、
「PEG/IGD/AUTO」からどれか選ぶ項目しかなさそうです。
デフォルトで「AUTO」を「PEG」に無理やり設定しても増設のRGBではBIOSの画面は映りません。
RGB端子があるモニタがあったので試してみたのですが、メインモニタがHDMIのみしかないので(そんなに設定変えませんが)不便ですね。

投稿日時 - 2018-01-24 19:22:09

ANo.1

ビデオカードの型名が不明ですが、BIOS画面が表示できないのであれば、カードがスロットに正しく刺さっていない、補助電源が必要であれば電源が接続されていない。BIOSで認識してないのでCMOSクリアをしてみる。後は電源容量が足りない。最近PCは電源容量が少ないものが多いので。
BIOSで画面表示でないのであればWindowsでも表示できません。

投稿日時 - 2018-01-24 04:40:40

補足

ありがとうございます。

Windowsは問題なく動いています。
電源ですかね。。

投稿日時 - 2018-01-24 19:15:23